居然报错了?如何安装Swoole Loader扩展呢?

                                        01关于问题

最近有小伙伴问我,说wordpress总裁主题安装有问题,怀疑是源码问题,既然有问题,那就解决呗,不要怀疑源码,都是经过测试的没问题了才发出来的。

其实我们经常会遇到这个问题,提示信息如下:

                                        02原因分析

一、很多人安装总裁主题安装前端显示错误

二、php必须7.4,那么有人问 我是7.4呀,为什么还不行?因为没安装扩展7.4

                                       03解决问题

1、下载Swoole Loader压缩包。

2:到指定目录/www/server/php/72/lib/php/extensions/no-debug-non-zts-20170718上传刚下载的压缩包Linux64位(非线程安全)里面的:swoole_loader72.so文件上传

3:到指定目录/www/server/php/72/etc/php.ini 拖到底部 写

extension=swoole_loader72.so

保存即可

以上步骤完成,到宝塔-软件商店-重启php7.4,到前台刷新会看到,是否安装swoole_loader:已安装

                                         04特别说明

其实并不是只有这个需要Swoole Loader扩展,包括安装其他主题等等,这东西都给他装上去就不会报错了,都是需要安装Swoole Loader扩展的。如果安装网站的时候发现报错:SWOOLEC loader ext not installed,也是要求安装Swoole Loader扩展的。
注:主要看系统,基本为Linux-非线程安全,看上面提示啥系统就按那个系统的php版本

发表评论

邮箱地址不会被公开。 必填项已用*标注

嘿,我是总裁,需要帮助随时找我哦